Installation on Raspberry Pi 3

Hi, I'm sorry if this is a basic question but I've been having trouble with the installation of rosflight on my raspberry pi 3. I'm running Raspbian Jessie on the Raspberry Pi, and I installed ROS kinetic using the online instructions. When I try to install ros-kinetic-rosflight-pkgs with sudo apt-get, I get the error that it can't find the package. I checked my sources list and I have 'packages.ros.org/ros/ubuntu jessie main' listed. I also tried installing from source but run into a similar issue when I run the rosdep install --ignore-src rosflight command.

When I run uname -m, the raspberry pi lists its architecture as armv7l, but none of the ros-kinetic packages are listed in the armhf folder on the ros packages website. However, the packages are listed in the arm64 and amd64 packages. I've tried looking around but couldn't find any postings with this issue. I saw in some of the other postings that people have rosflight up and running on the pi, so I don't think it's an architecture issue, but I'm not exactly sure what could be going wrong. Any help would be greatly appreciated.

Thank you.

Comments

  • 3 Comments sorted by Votes Date Added
  • Hi @Rdhillo, sorry for your troubles. What error message do you get when you run the rosdep install --ignore-src rosflight command you mentioned?

  • Sorry for the late response @dpkoch , I got it figured out. It turns out I was using the wrong command for installing on the PI. On the ROS installation website, they say to use the 'rosinstall generator' to load any additional packages onto the raspberry pi. In case anyone else has an issue, the ROS website gives this as the example for installing 'ros_comm', 'ros_control', and 'joystick_drivers' as additional packages
    rosinstall_generator ros_comm ros_control joystick_drivers --rosdistro kinetic --deps --wet-only --tar > kinetic-custom_ros.rosinstall
    Once I used that command with the rosflight packages and appropriate distribution, they downloaded fine, so really I just needed to read more carefully.

  • Glad you got it figured out @Rdhillo, thanks for sharing what you learned!

Sign In or Register to comment.