Airspeed errors

edited September 2017 in Firmware Vote Up0Vote Down

I recevied this message from Seth at U of Cincinatti:

The new build of the firmware do not seem to work at all. I have tried this on 16.04 with both rev 5 and 6. The ROS node just spams Detected time offset of 1506704629.(some random decimal) over and over and over. The airspeed sensor still doesn't work I have tried everything I can think of and nothing works. I really need to be able to receive airspeed data and I can't do so on old builds of rosflight or new.

Best Answer

  • 3 Comments sorted by Votes Date Added
  • Ha! I figured out how to reproduce your issue.

    I'm sorry about this, we really have been bad about maintaining compatibility with rev 5 nazes. I'll try to do better about testing for these bugs. (It's a problem with rev5 and rev6 compatibility)

Answers

  • edited September 2017 Vote Up0Vote Down

    Seth, in your experiments has the airspeed sensor been powered? The naze has a funny circuit where the I2C port is only powered if the board is being powered from the 5V rail on the servo output or RC input. The 5V from the USB connector is not forwarded to the i2c

  • Also, is the ROS node running on a board computer (like an odroid)? If so, does it have internet or a RTC battery? How often does it report that error?

Sign In or Register to comment.