Autopilot error: rc lost

I am using Naze 32 hardware and the receiver is RX8R, and I have even bound it to the Taranis remote controller. I connected it to the actual hardware and ran the rosflight_io node, but the message said rc lost. I am lacking a lot. I would appreciate it if you could let me know if I am missing something.

I’m surprised you have Naze32 hardware! I haven’t used that hardware myself, but 1.3 should work with that board and receiver. You may need to set the RC_TYPE parameter as mentioned here: Also check to make sure your hardware is properly configured:

thank you for the reply. I loaded the firmware into the board using the Sbus method by setting the RC_TYPE parameter to 1. I kept trying, but the RC lost message keeps popping up in the message window. I also carefully re-read and checked the hardware settings, but there were no problems. I may have missed something. I tried everything I could, but the problem wasn’t solved. The receiver and controller are bound, and as a result of checking through rostopic echo /rc_raw, the stick value does not move… May I know if there is something I can try?

sorry, ros2 topic echo /rc_raw

I would double check your wiring to the receiver and the flight controller. Is there any configuration that you can do for the receiver? ROSflight only supports 8 channels, so maybe you need to set some kind of channel mode on the reciever. You could also try flashing the Naze32 with Cleanflight (or Betaflight, if it supports it) and see if you can get things configured and working with an alternate firmware, to make sure that your hardware is working. Otherwise I’m not sure what the issue would be. We’re not planning on supporting the Naze32 for future versions of ROSflight and as such have not done any recent testing with that hardware.

images I flashed the firmware to v1.2.0 version on the naze32 hardware. Is it possible that the sbus method does not work in version v1.2.0?
And I know the naze32 wiring diagram accurately and am using the receiver, GND, 5V, and UART 2 RX.

When looking at the code, it looks like SBUS should be on UART 1. Try rewiring it and see if that works. 1.3 should support SBUS.

UART1 controls the USB connection on the NAZE32 rev6. The manual says that the RX and TX pins on the top of the board are connected to UART1 and shared with the USB connection.
I want to enable UART2, can you tell me which side of the code I need to modify? And I’m curious if there is a code to activate UART.

I found that information here: