Is Rosflight comaptible with ROS Noetic?

I’m very sorry if this is a stupid question but although the wiki page clearly states that RosFlight does not support integration with ROS Noetic, I’m not so sure if that is the case.

When I tried running the gazebo simulation on Ubuntu 20.04 with ROS Noetic I didn’t encounter any big problems (I didn’t get the drone to do anything, but that I think was a problem with my machine or with PyGame). If it really isn’t supported/recommend to use Noetic, will a potential update come in the near future, or will someone find the time to upload some tips for migrating (I think that working through the code and making the necessary changes for migration is a very good exercises in learning the infrastructure of the project)? If it is the case that Noetic is supported, but the documentation isn’t updated, could I do anything to help and update it?

Thank you in advance, and apologies if this question was already asked.

It is runing on focal with noetic for me.

Do you have error codes in the rosflightIO output when you launch the simulation?

No errors. I have tried again to launch the simulation, but to no avail. It may be that I don’t fully understand what to do, and unfortunately the docs aren’t quite useful in helping me with the problems I encountered (I don’t blame the developers, Rosflight seems a great project and I thank everyone who works on such open source projects). I’m sure it just a small thing that keeps me from controlling the sim (I do get it to start, and I can retrieve param info from rosfligth_io, but I can’t seem to understand what to do from here).
I would gladly help in uploading the wiki if I do somehow get it to work (and of course understand the infrastructure of the project)

If you also have no error_code under rostopic pub /status then it is suspicious.

I have attached my configuration for parameters that I set on launch of the multirotor.launch


They are not all required but they cover the necessary ones.

In case you haven’t yet, ensure to calibrate the simulated sensors using
rosservice call /calibrate_imu


rosservice call /calibrate_baro

Thanks a lot for the quick reply.
I have already tried in one way or another what you are suggesting, and the commands yield no errors.
With that in mind, I am again considering that the problems comes from the actual RC transmission (as I understand it isn’t possible to arm the vehicle from commands, so I can’t really go further with my testing if indeed the problems comes from the controller/keyboard). The rc_joy seems to start correctly, but I don’t know a method to actually check if things are actually sent (echoing the /command or /status doesn’t show anything if I move the joystick, so no input is given), and rc_keyboard doesn’t seem to work (it opens pygame in the taskbar but no actual window exists).

You should be able to see the commands under the respective ~RC topic in case of multirotor.launch under /multirotor/RC as described in the Gazebo simulation documentation here.
If you don’t’ see RC commands, then I would suspect that the rc_joy does not work as expected for the rc keyboard. I only use a Xbox controller where pygame does not seem to have problems. You can try running the rc_joy separetly and adding print outs within the Python script. This would be a very straightforward way to further narrow it down.

Alternatively, if you verify that the RC commands are working as expected, you can also investigate choosing different arm channels or manually publishing to the RC topic to trigger the appropriate arming channel. You can simply test this by selecting for example the ARM_CHANNEL 4 and do a rostopic pub /multirotor/RC ... ( instead of ... press tabulator twice to autocomplete and fill in a 2000 value for the 5th element in the array.

Indeed, if I run rc_joy and then check /multicopter/RC with rostopic echo I see that messages are published

values: [1495, 1000, 1504, 1497, 1506, 1000, 1000, 1000]

and if I stop rc_joy no message is published. These are all good signs, but if I move my joysticks the values published do not change (even tough the controller is working (tested with jstest-gtk )).
Another thing that I realized, the rosflight-io terminal sometimes gives the error:

Autopilot ERROR: RC lost

(this seems to happen when i want to manually publish to /multirotor/rc with rostopic pub)

P.S. Thank you a lot for taking the time to help me, I’m sure that it is a very small thing that gives these problems, but unfortunately I’m not fully capable of explaining my situation on the forums. Should I open another discussion topic ?(this one drifted a bit from the subject in title)