Unable to arm: Invalid failsafe setting

I want to know if the simulation works in Gazebo using Rosflight. It won’t start at the moment. I want to solve this problem. I also want

to know the parameters of the multicopter. Help me

Are you using the ROS1 version or the ROS2 version found on the main branches?

We’ve been spending most of our recent development time on fixedwings, but multirotors should also be working in Gazebo. Try following the instructions for getting a fixedwing flying in the simulator, and if that works then do the same for multirotor: https://github.com/rosflight/rosflight_ros_pkgs?tab=readme-ov-file#running-the-gazebo-simulation

You can also find more information on the git-main version of the documentation:

Thank you for reading this… However, we have not yet solved the problem of Unable to arm: Invalid fail-safe setting. I tried based on the link, but it’s still the same.

Sorry, I missed your reply here. It sounds like from a different post that you got this working, what was the issue?

hello. I solved this problem. I used the rosflight_utils multirotor_init_firmware.launch.py ​​code to launch the initial firmware, but I could not solve the problem, so I manually set the parameters one by one, and no error message appeared.

Makes sense, I made those parameter files briefly as a convenience. We’ll need to revisit those at some point.